Exploratory Community

Windows: When entering non-ascii characters in R Script Data Source, the value got garbled in the data frame

#1

Suppose you enter non-ASCII characters like the below screenshot, you might see garbled characters when checking the “Auto Detect Data Type” checkbox.

If you encounter the issue, please uncheck the “Auto Detec Data Type”.

If you want to apply “Auto Detect Data Type”, you can append below to your script.

%>% type_convert(locale=locale(encoding="Windows-1251"))