When trying to sign up, "There was a problem processing your request" is displayed and sign-up cannot be completed

Issue

When signing up to create an Exploratory account, “There was a problem processing your request” may be displayed, and the sign-up process may not be completed.

Cause

It is assumed that the cause is your firewall blocking POST requests to our site (https://exploratory.io).

Solution

Please change your firewall settings to allow POST requests to https://exploratory.io, or request the department in charge of managing your firewall to do so.

If the problem is not resolved after trying the above solution, or if you are encountering other issues, please contact our support team (support@exploratory.io).