Exploratory Community

Unable import date properly

#2

I think you are seeing numbers instead of Dates. You can convert those Excel date numbers to Date values from “Change Data Type” option.