Exploratory Community

R 3.6 Support with Exploratory Desktop

#1

R 3.6 Support with Exploratory

Currently, we’re in the middle of supporting R 3.6 with Exploratory Desktop. Please stay with R 3.5 until we released the new Exploratory Desktop version which supports R 3.6. (NOTE: Exploratory Desktop version 5.2.0 still does not support R3.6)

If you already upgraded to R 3.6, you might have the issue that you cannot open existing projects in Exploratory Desktop. If this is the case, please uninstall R 3.6 and then re-start Exploratory Desktop. This will install R 3.5 again on your computer. If you have any questions/issues around this R 3.6 upgrade, please feel free to contact us support@exploratory.io or via chat available on exploratory.io web site.

#2

I had just installed R 3.6 because R-Studio required that to work. Now the new version of Exploratory doesn’t let me open my files. I uninstalled R 3.6 and tried opening the latest version of Exploratory. No install of R 3.5 happens and I get the same error in opening my files.

#3

Hi Rajiv

If you use Mac version, could you please try below command from a Terminal and restart Exploratory Desktop?

sudo rm -rf /Library/Frameworks/R.framework
/Applications/R.app
/usr/bin/R
/usr/bin/Rscript
/usr/local/bin/R

#4

We just released Exploratory 5.2.1 that supports R3.6!

You can download it from https://exploratory.io/download