Problem
When attempting to publish large content such as charts, dashboards, etc, the publish process fails.
Cause
It is possible that proxy server settings such as http_proxy
and https_proxy
are configured in the Docker environment where the Exploratory server is running. These settings might interfere with external network communication during the publish process.
Solution
Follow the steps below to remove proxy settings from the Docker environment and resolve the publish failure.
-
Check the Container ID
Run thedocker ps
command to check the container ID of the Exploratory instance. Example output:$ docker ps CONTAINER ID IMAGE ... NAMES 4bb63a323561 exploratory:11.5.1 ... exploratory-exploratory-1
-
Check for Proxy Settings
Rundocker inspect <container_id>
and check theEnv
section underConfig
. If you see entries like the following, it means a proxy server is configured:"Env": [ "http_proxy=http://proxy.host", "HTTP_PROXY=http://proxy.host", "https_proxy=http://proxy.host", "HTTPS_PROXY=http://proxy.host", ]
-
Update
docker-compose.yml
In thedocker-compose.yml
file, add the following 4 lines to theenvironment:
section of each service (mongodb, exploratory, nginx, scheduler, rserve, webdav, agendash). Ifenvironment:
does not exist, create it.- http_proxy= - https_proxy= - HTTP_PROXY= - HTTPS_PROXY=
Example for the
exploratory
service:services: exploratory: image: exploratory:11.5.1 environment: - EXPL_ADMIN_FIRSTNAME=Admin - EXPL_ADMIN_LASTNAME=User ... - http_proxy= - https_proxy= - HTTP_PROXY= - HTTPS_PROXY=
-
Restart the Docker Containers
$ docker-compose down $ docker-compose up -d
-
Verify Changes
Repeat steps 1 and 2 to confirm that proxy settings have been removed.