Exploratory not starting up on Windows 7


I downloaded the latest version ( of Exploratory today and its not properly starting up at all even after 10 minutes of loading. Please advise.

I have run previous versions before OK, just appears this version is causing an issue.

Many thanks,

Hi James,
Thank you for reporting this. We are looking into this issue.

Hi James ,

If you open task manager and stop any running Exploratory.exe processes then try to open the app again does the issue still happen?


Hi Ryan,

I have already tried doing this several times with the task manager, but still come up across the same issue. Please advise.


@jb2499 Sorry for the delayed response.

Can you tell me which Windows version you are using and if it’s 32 or 64 bit.
Also how much RAM do you have installed out of curiosity.

I worked with James and figured out that Exploratory’s repository (.exploratory directory) was in a strange state and causing this hang. James kindly provided us the copy of his .exploratory directory. So we will analyze it and work on a fix to prevent this to happen.

I seem to be having a similar issue based on symptoms. Was a fix action discovered as there was not one mentioned here?