Exploratory Community

Exploratory Crashing when opening data file

#1

Since upgrading to Mac Catalina, every time I open a datafile (e.g. csv) within a project it crashes Exploratory. Then when I open Exploratory back up I have to remove “rserve” from activity monitor. I repeat the process and it crashes again when attempting to open a csv data file. I tried removing the application, R, and Git entirely from my computer and starting over with a fresh install – no fix. Any thoughts?
Thanks for you help!

  • Daniel
#2

We’ll look into this and get back shortly!

#3

Can you let me know the Exploratory version are you using?

The latest version has been notarized and we are not seeing such issue. But there might be some other reasons.

We have a troubleshooting guide for Catalina users as well.

#4

Hi Kan. I am using the latest Mac OS update 10.15.1 and Exploratory 5.4.0. Can you tell me how to make sure I’ve completely removed Exploratory from my Mac? Perhaps there was some problem with the initial install?
– I have tried to remove everything and do a fresh install, but perhaps I am missing something. Not sure if this would help solve the issue, but something I can try.
Of note, I never had this problem until I upgraded to Catalina and the newest version of Exploratory. I did this at the same time so not sure which change created the issue.

Thanks for your help!

#5

Hi Kan. Any updates? I still can not open a data file without it immediately crashing exploratory. I went through the link you provided. I also tried removing exploratory, r, and git and reinstalling. However, nothing seems to work. Any thoughts?
thanks for your help.

#6

Can you quickly get on zoom or google hangout so that we can take a look?

#7

yep. I have both. send me a link and I’ll join.